New! – idealo for WooCommerce – The official idealo Plugin!

PHP 7.2+ Update

idealo for WooCommerce updates won’t support PHP version lower than 7.2 – we recommend updating PHP to version 7.2 or higher.

Why is it necessary to update PHP?

The main reasons why PHP should be updated to a recent version are security, compatibility and performance.

Many Plugins for WordPress nowadays already have higher PHP requirements and WordPress and WooCommerce are also recommending higher versions already as a minimum (WordPress 7.4 https://wordpress.org/about/requirements/, WooCommerce 7.3 https://docs.woocommerce.com/document/server-requirements/), to ensure security and functionality. 

Websites with an outdated PHP version could be vulnerable to attacks or just could crash due to a software update, that could not be compatible anymore with the outdated PHP environment.

Besides making systems more secure and stable, updating the PHP version also often improves the speed of sites, as versions higher than 7.2 are more efficient in terms of performance.

How to update PHP?

PHP versions are managed by the hoster. In case of doubt about how to perform PHP updates safely, or if the updating options are not accessible through the back end, please review the documentation of your service provider, for how to update PHP.

If no documentation is available, or you are still unsure how to proceed, contact the support of your hosting provider and ask for assistance.

Please note that updating PHP can be a risky procedure and lead to data loss if no working backups are in place.

What happens if I don’t update?

idealo for WooCommerce will still work, but not longer be supported by us. All future updates will not be compatible with lower PHP versions and therefore, if you experience problems with idealo for WooCommerce, we will not be able to provide any support for your outdated environment.

So we strongly recommend that you update your PHP version.